Setup new Macbook

Install Iterm2:
http://iterm2.com/downloads.html
https://github.com/robbyrussell/oh-my-zsh

Set hot key: iTerm2 -> Preferences -> Key -> + (key mapping) -> Shortcult: cmd + shift + t | Action: Select menu item... | Duplicate Tab

Enable Natural Text Editing (option + arrow keys to move by word, FN + arrow keys to jump to begin/end of line): Preferences... > Profiles > Keys > Key Mappings tab > Presets > Natural Text Editing
Install Xcode
Run xcode-select --install from terminal or Go to App Store and install Xcode
Install xcode command line tools at https://developer.apple.com/download/more/

Install Homebrew
ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"

Install posgresql
http://postgresapp.com
brew install postgresql

Install Source Tree
https://www.sourcetreeapp.com

Install RVM
\curl -sSL https://get.rvm.io | bash -s stable

# Ruby < 2.4 requires openssl 1.1
export PATH="/opt/homebrew/opt/openssl@1.1/bin:$PATH"
export LDFLAGS="-L/opt/homebrew/opt/openssl@1.1/lib"
export CPPFLAGS="-I/opt/homebrew/opt/openssl@1.1/include"
export PATH="/usr/local/opt/libpq/bin:$PATH"
# Ruby flags for M1
export RUBY_CFLAGS=-DUSE_FFI_CLOSURE_ALLOC
export optflags="-Wno-error=implicit-function-declaration"

rvm install 2.3.1 --with-openssl-dir=/opt/homebrew/opt/openssl@1.1

Install NVM
https://tecadmin.net/install-nvm-macos-with-homebrew/
nvm install node (latest version) or nvm install 14 (specific version)
nvm use 14

Install QT - Needed to run Capybara
brew install qt

ImageMagick
brew install imagemagick --build-from-source

Install Heroku Toolbelt
https://devcenter.heroku.com/articles/heroku-command-line

Install Sublime Text 3
- Create a shortcut: ln -s "/Applications/Sublime Text.app/Contents/SharedSupport/bin/subl" /usr/local/bin/subl
- Add alias echo "alias s=subl" >> ~/.zshrc